[TUTO] Télécodage et calibration d'un NAC / RCC / CIROCCO SANS Diagbox via Arduino

Discussion dans 'NAC' démarrée par VLud, 2 Septembre 2020.

  1. marcins

    marcins Peugeot Addict

    Inscrit depuis le :
    23 Novembre 2020
    Messages :
    59
    "J'aime" reçus :
    26
    when you ask something provide more detail

    NAC WAVE (X) - and calibration inside + attch config file
    no one is a wizard can't tell you without data...

    beep is from rear speaker... or when switched in BSI from com2008..
     
  2. tech73

    tech73 Membre régulier

    Inscrit depuis le :
    3 Avril 2020
    Messages :
    26
    "J'aime" reçus :
    1
    nac w3 from 2019 jumpy i changed calibration i believe calibration is peugeot 208 bluetooth name is peugeot

    car is citroen c4 2007 i can get beep from the comms unit when parking but not from nac i did try smeg iv2 and got beep beep from rear speakers but nac nothing just volume of radio goes a little lower

    i can find the exact calibration if it will help

    thank you for your reply hopefully you can help me with this
     
  3. tech73

    tech73 Membre régulier

    Inscrit depuis le :
    3 Avril 2020
    Messages :
    26
    "J'aime" reçus :
    1
     

    Pièces jointes:

  4. marcins

    marcins Peugeot Addict

    Inscrit depuis le :
    23 Novembre 2020
    Messages :
    59
    "J'aime" reçus :
    26
    that's 5008 calibration's try load in c4 one
     
  5. tech73

    tech73 Membre régulier

    Inscrit depuis le :
    3 Avril 2020
    Messages :
    26
    "J'aime" reçus :
    1
    i have just switched off the beep at steering wheel comms unit and you can hear the beep beep through nac speakers but very very low can barely hear it is there a setting for aas volume ?
     
  6. marcins

    marcins Peugeot Addict

    Inscrit depuis le :
    23 Novembre 2020
    Messages :
    59
    "J'aime" reçus :
    26
    yes it is
    but in calibration zone
    write frame 0100
    2E0100XX where XX is volume from 1-8

    first check your value
    send
    220100

    stock is 33

    to change

    >764:664
    1003
    2E010055 or 11-low 88-very loud
    that't for front and rear
     
  7. tech73

    tech73 Membre régulier

    Inscrit depuis le :
    3 Avril 2020
    Messages :
    26
    "J'aime" reçus :
    1
    im sorry but i do not understand how to do this could you please explain for me thank you
     
  8. jianlinglai123

    jianlinglai123 Nouveau membre

    Inscrit depuis le :
    13 Mai 2021
    Messages :
    1
    "J'aime" reçus :
    0
  9. tech73

    tech73 Membre régulier

    Inscrit depuis le :
    3 Avril 2020
    Messages :
    26
    "J'aime" reçus :
    1
    do i use the psa diag software to modify zones i realy am confused
     
  10. marcins

    marcins Peugeot Addict

    Inscrit depuis le :
    23 Novembre 2020
    Messages :
    59
    "J'aime" reçus :
    26
    here you have config file to upload , this change only volume on AAS :) if you need louder open with notepadd++ and change to 66 or 77
    now is set to 43
     
    #2410 marcins, 16 Juillet 2021
    Dernière édition: 17 Juillet 2021
  11. tech73

    tech73 Membre régulier

    Inscrit depuis le :
    3 Avril 2020
    Messages :
    26
    "J'aime" reçus :
    1
    how do i upload it ? i have no idea honest :(
     
  12. marcins

    marcins Peugeot Addict

    Inscrit depuis le :
    23 Novembre 2020
    Messages :
    59
    "J'aime" reçus :
    26
    @VLud tool for NAC / restore parameters button
     
  13. tech73

    tech73 Membre régulier

    Inscrit depuis le :
    3 Avril 2020
    Messages :
    26
    "J'aime" reçus :
    1
    i have tried that but program gives error
     
  14. marcins

    marcins Peugeot Addict

    Inscrit depuis le :
    23 Novembre 2020
    Messages :
    59
    "J'aime" reçus :
    26
    so manual way
    in terminal post 2406

    if you don't understand howto can't help
     
  15. tech73

    tech73 Membre régulier

    Inscrit depuis le :
    3 Avril 2020
    Messages :
    26
    "J'aime" reçus :
    1
    how do you do this manual way i do not understand and aas volume still very low can someone please help me

    thank you
     
  16. tech73

    tech73 Membre régulier

    Inscrit depuis le :
    3 Avril 2020
    Messages :
    26
    "J'aime" reçus :
    1
    could someone please explain how this is done and what software also can this be done with the nac in the car i am finding this very difficult to understand and no way of knowing what and how to change zones and send frames

    thank you
     
  17. marcins

    marcins Peugeot Addict

    Inscrit depuis le :
    23 Novembre 2020
    Messages :
    59
    "J'aime" reçus :
    26
    https://github.com/ludwig-v/arduino-psa-diag

    and you have calibration from 5008 where is set to 3 rears beep
    load one from C4_II-9692638280 this one have louder settings
     
    #2417 marcins, 17 Juillet 2021
    Dernière édition: 17 Juillet 2021
  18. tech73

    tech73 Membre régulier

    Inscrit depuis le :
    3 Avril 2020
    Messages :
    26
    "J'aime" reçus :
    1
    i am using c4II since yesterday and have also tried ds3 still the same
     
  19. tech73

    tech73 Membre régulier

    Inscrit depuis le :
    3 Avril 2020
    Messages :
    26
    "J'aime" reçus :
    1
    @marcins is there any way of editing the c4II cal file to include modified aas settings?
    my other question is looking at the link you sent i see it has zones.md do i upload that script and then run the console to edit aas settings sorry but i have no issue using the usual psa diag for configuration but having difficulties with the modification of the aas zones

    thanks hope you can help :)
     
    #2419 tech73, 18 Juillet 2021
    Dernière édition: 18 Juillet 2021
  20. diluca80

    diluca80 Nouveau membre

    Inscrit depuis le :
    10 Novembre 2020
    Messages :
    4
    "J'aime" reçus :
    0
    good morning sorry for the inconvenience, do you know how to enable the speed limit on the top left and display the name of the radio stations in the top center? in my old peugeot 208 i could see the speed limit sign and the radio station nme.
     
  21. Corin

    Corin Membre

    Inscrit depuis le :
    23 Octobre 2018
    Messages :
    24
    "J'aime" reçus :
    1
    Hi.
    Do you have an idea why show me the area is not mapped and does not display the estimated time until arrival on cirocco?
    On NAC are displayed.
    3008 Cirocco and 2008 the car with 2008 cal
     

    Pièces jointes:

    • 1.jpg
      1.jpg
      Taille du fichier:
      144.8 Ko
      Affichages:
      71
    • 2.jpg
      2.jpg
      Taille du fichier:
      182.8 Ko
      Affichages:
      67
    • 3.jpg
      3.jpg
      Taille du fichier:
      180.8 Ko
      Affichages:
      65
    • 4.jpg
      4.jpg
      Taille du fichier:
      143.3 Ko
      Affichages:
      66
  22. deadre

    deadre Nouveau membre

    Inscrit depuis le :
    6 Février 2021
    Messages :
    1
    "J'aime" reçus :
    3
    Hello VLud, thank you for the information.
    I have a question for you or others that might know, which exact models are considered a Wave3 and which are Wave4?

    Is the only "true" W4 NAC, a NAC with a label that says: NAC EUR 19W4 with a FCC ID: ZFW-HW19W4?

    Because I have a NAC that has a wave4 text on the label, but the other information on the label is conflicting...
    It states: NAC EUR wave4 / W4_EU_B4DAB, Continental-WAVE4EUCEMXX, but the FCC ID is the same of a Wave3 NAC... FCC ID: ZFW-NACEUR3.

    19w4.jpg "True" W4

    wave3.jpg Wave 3

    wave4.jpg A Wave 4, but not really a Wave 4? :)
     
  23. tech73

    tech73 Membre régulier

    Inscrit depuis le :
    3 Avril 2020
    Messages :
    26
    "J'aime" reçus :
    1
    hello everyone i have tried various ways but unable to do it or understand the calibration of my aas volume nac w3 calibration c4II
    the volume of the aas is so quiet you cant hardly hear it there are posts above on changing it but none of which i understand or are able to complete
    could someone please help me with this after all i thought this forum was for us to help each other but i am losing faith as questions go unanswered and it seems that the compilers of the software after doing such a great job in what they have done some assume we are all wizards which we are not and this is why we come here for help

    thank you and well done Vlud and others who have done such excellent work here
     
    #2423 tech73, 19 Juillet 2021
    Dernière édition: 19 Juillet 2021
  24. VLud

    VLud Lion de Bronze

    Inscrit depuis le :
    19 Janvier 2018
    Messages :
    1 575
    "J'aime" reçus :
    653
    You can also keep your remarks for you, I or everybody else do not have any sort of obligation at replying to you.
    You want to retrofit things, fine, but assume your very particular situation and learn how to fix your own ideas, there is no easy answer when you use an ECU in unplanned environment ... and I don't have any answer anyway.
     
    hangway2 et Calico aiment cela.
  25. V3nn3tj3

    V3nn3tj3 Membre régulier

    Inscrit depuis le :
    11 Juin 2019
    Messages :
    27
    "J'aime" reçus :
    14
    Question, i have installed my NAC and all works now. Only one thing i can't seem to get working. The parkingsensors/radar does not show up on the screen.
    NAC came from a DS3 (with camera and maybe without sensors), i have not changed calibrarion.
    I can hear the 'blip, blip, blip' fine.

    Anyone got an idea?
     
  26. marcins

    marcins Peugeot Addict

    Inscrit depuis le :
    23 Novembre 2020
    Messages :
    59
    "J'aime" reçus :
    26
    more like conf need to be adjusted add you conf backup without vin and uid
     
  27. tech73

    tech73 Membre régulier

    Inscrit depuis le :
    3 Avril 2020
    Messages :
    26
    "J'aime" reçus :
    1
    can anyone help me with nac installed in 2007 c4 the rear camera image colours are wrong if you see the black circled areas the wall should look like red brick the other circle showing a drinks container should be blue but it is green i can only get reverse image 180 degree if config as virtual panoramic assistance
    i also still cannot get the beep sound from speakers you can only just hear it

    has anyone had this image problem before ?the cam is from a 2019 c5 aircross

    i have included details from label of my nac

    calibration 9692638280 c4II

    thank you in advance DSC_2496.JPG
     

    Pièces jointes:

  28. tech73

    tech73 Membre régulier

    Inscrit depuis le :
    3 Avril 2020
    Messages :
    26
    "J'aime" reçus :
    1
    @VLud i have great respect for the work you have done it is truly amazing achievment i take my hat off to you i understand the need to learn but if others could point me in the right direction on the way in which the great work you have done i can implement i am able to learn using softwares but im sorry i do struggle with arduino .
    i dont expect you to do the work for me but maybe point me in the right direction in implementing your tools to achieve my goal .

    i sincerely aplaud your work it is amazing
     
  29. tech73

    tech73 Membre régulier

    Inscrit depuis le :
    3 Avril 2020
    Messages :
    26
    "J'aime" reçus :
    1
    i have had some success with the AAS volume not known to me but the previous owner had disconnected the rear speakers
    as a diagbox session showed them open circuit i did actuator test and fronts emit test tones ok rear nothing im sure previous owner had an amplifier in the rear
    i feel such a fool now and i do appologise for any way i have upset any of the forum members sincerely sorry
    AAS now really loud

    however i do have one question my bsi does not send the command for rear assistance camera even though it is enabled in the bsi

    my question is regards to the only way i can see the camera image but in terrible colours is by configuration of the nac to virtual 180 degree panoramic camera

    may i ask what the difference is and is it possible to modify the arduino sketch to send correct frame for avr

    i feel realy bad now after my previous posts but the only thing not working is the rear camera only if configured the way it is see the image above and how awfull it is i know the image is clear from the camera when tested with a smeg iv2

    i hope i am not annoying anyone and that maybe someone can assist with the camera issue

    thank you kindly in advance and please accept my sincere appologies
     
  30. VLud

    VLud Lion de Bronze

    Inscrit depuis le :
    19 Janvier 2018
    Messages :
    1 575
    "J'aime" reçus :
    653

Partager cette page

  1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière.
    Rejeter la notification